Troubleshooting
Problem
When try to extract business term from PDF document causing the error "Processing this PDF requires more resources than are currently allocated. To increase the resources for this feature, please contact your system administrator".
Symptom
When extracting business term from large pdf file returns the following error
or the error "Processing this PDF requires more resources than are currently allocated"
Cause
Default settings for knol deployment.
containers: - env: - name: MEMORY_LIMIT value: 1500Mi - name: CPU_LIMIT value: 1000m - name: MEMORY_REQUEST value: 1500Mi - name: CPU_REQUEST value: 500m
To process PDF, request_units.py script in the knol pod, it is checking to ensure the minimum requested memory is 8G
After the fix, it should have the values similar to below
oc edit deployment knol-knol -o yaml
Environment
- Cloud Pak for Data 2.5, 3.0
- Watson Knowledge Studio
- OpenShift 3.11, 4.3
Diagnosing The Problem
1. Check the knol pod status
oc get pods -o wide | grep knol
2. Check the node resource utilization for knol pod.
oc describe node $(oc get pods -o wide | grep knol| awk '{ print $7 }'
Resolving The Problem
1. Increase cpu/memory limit for the knol
oc set env deployment/knol-knol MEMORY_LIMIT=16Gi CPU_LIMIT=8 MEMORY_REQUEST=16Gi CPU_REQUEST=8 oc set resources deployment knol-knol --requests=cpu=8,memory=16Gi --limits=cpu=8,memory=16Gi
2. Check the Resource limit
https://<cluster-url>
/gov/document-extract/api/v1/status
This should return "
system_has_enough_resources:true"Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSHGYS","label":"IBM Cloud Pak for Data"},"ARM Category":[{"code":"a8m0z000000GpDtAAK","label":"Cataloging and governing data"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
09 July 2020
UID
ibm16245328