Troubleshooting
Problem
User launches Controller client. User does not receive a database selection (choise of databases) screen. Instead, the user receives an error message.
Problem only affects one user.
Symptom
Depending on the version of Controller, you may see a different screen error message:
Controller 10.2.1:
System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.IO.FileNotFoundException: Could not find file 'C:\Program Files\IBM\cognos\ccr_64\Data\default.Udl'.
at Microsoft.VisualBasic.ErrObject.Raise(Int32 Number, Object Source, Object Description, Object HelpFile, Object HelpContext)
at ControllerServerCommon.RaiseErrSrv.RaiseError(String sUser, Int32 lErrNo, String sErrSource, String sErrDesc, String sErrHelpFile, Int32 lErrHelpContext)
at FrServerB.ServerInfo.GetDBRelease(String sGuid, String sUser)
at Cognos.Controller.Proxy.CCRWS.ServerInfo_GetDBRelease(String sGuid, String sUser)
--- End of inner exception stack trace ---.
Controller 10.2:
Server was unable to process request. ---> Could not find file 'C:\Program Files\ibm\cognos\ccr_64\Data\default.Udl'.
Cause
Both of the following are true:
(1) The user has recently clicked on the menu item "Maintain - Database - Database Selection Mode", which has unticked the setting.
- In other words (by clicking on that menu item) it has disabled database selection mode (so it is now unticked):
This means that the end-user does NOT get a choice of databases (to select from) when they launch Controller.
(2) The customer has not got a Controller database connection which is named: default
Environment
By design, Controller can be configured to either:
- Give end users a list of multiple databases when they logon
- This is known as using SelectDb
- Or automatically log the end user into only one database
- This is known as disabling SelectDb
If SelectDb is disabled ('False') then Controller expects there will be a database connection called 'default' (case-sensitive) defined on the application server.
- TIP: For more details, see separate IBM Technote #1347818.
Resolving The Problem
Solution #1 (recommended/easiest/quickest)
Change the setting on your client PC (and/or Citrix server) so all users have SelectDb enabled.
Steps:
1. Logon to 'bad' PC as the 'bad' end user's Windows username/password
2. Click 'Start - Run'
3. %APPDATA% <Enter>
4. Open subfolders 'Cognos' then 'ccr'
5. Open file 'ccr.config' inside NOTEPAD.EXE
6. Search for the string 'SelectDb'
7. Modify this line so it reads:
TIP: If you are deploying Controller via Citrix/Terminal Server, please ask your Citrix/TS I.T. administrator to perform the above (inside the end user's Windows profile) on their behalf.
Solution #2
Rename your 'main' (default) database connection to: default
Steps
1. Obtain a short period of downtime
2. Logon to the Controller application server as an administrator
3. Launch 'Controller Configuration' from the start menu
4. Open section 'Database Connections'
5. Double-click on 'main' database (for example, called 'ControllerLive')
6. Modify the value for 'name' to: default
7. Click 'Save'
8. Open section 'Report Server'
9. Test.
Change the setting on your client PC (and/or Citrix server) so all users have SelectDb enabled.
Steps:
1. Logon to 'bad' PC as the 'bad' end user's Windows username/password
2. Click 'Start - Run'
3. %APPDATA% <Enter>
4. Open subfolders 'Cognos' then 'ccr'
5. Open file 'ccr.config' inside NOTEPAD.EXE
6. Search for the string 'SelectDb'
7. Modify this line so it reads:
-
- <add key="SelectDb" value="True" />
TIP: If you are deploying Controller via Citrix/Terminal Server, please ask your Citrix/TS I.T. administrator to perform the above (inside the end user's Windows profile) on their behalf.
Solution #2
Rename your 'main' (default) database connection to: default
- IMPORTANT: The name of this connection is CASE SENSITIVE
Steps
1. Obtain a short period of downtime
2. Logon to the Controller application server as an administrator
3. Launch 'Controller Configuration' from the start menu
4. Open section 'Database Connections'
5. Double-click on 'main' database (for example, called 'ControllerLive')
6. Modify the value for 'name' to: default
- IMPORTANT: The name of this connection is *CASE SENSITIVE* (it must be all lowercase)
7. Click 'Save'
8. Open section 'Report Server'
- If the menu item 'Repair' is available (not greyed out) then click this button
9. Test.
Related Information
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Historical Number
1031868
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Document Information
Modified date:
27 February 2019
UID
swg21382310