Troubleshooting
Problem
Installation of IBM Planning Analytics for Excel fails on step 6. Many files/folders are missing from the installation location.
Cause
A previous failed attempt of a Planning Analytics for Excel installation is still running or is still active in Task Manager.
Diagnosing The Problem
Review the installation logs:
tl-COR-2.0-xx.x-xxxxxxxx_xxxx.txt has these errors. This is a result of the *.dlls missing from the installation location
- Error: Failed system command "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\regasm.exe /codebase "C:\Program Files\ibm\cognos\IBM for Microsoft Office\CognosOfficeInterfaceAddin12.dll" ". Error: Application has returned exit code "100".
- Error: Failed system command "C:\Windows\system32\regsvr32.exe /s "C:\Program Files\ibm\cognos\IBM for Microsoft Office\CognosOfficeShim12.dll" ". Error: Application has returned exit code "3"
corredist-inst-COR_APP-AW64-ML-RTM-11.0.xx.x-0-.xxxx.txt. This error indicates there is another installation pending/not finished
- Failed to grab execution mutex. System error 258.
- MainEngineThread is returning 1618
Resolving The Problem
To resolve this issue:
- Uninstall the current failed installation
- Delete the folder and everything under C:\Program Files\ibm\cognos\IBM for Microsoft Office
- Reboot the laptop/system
- Re-install as Administrator
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"ARM Category":[{"code":"a8m0z000000GoRcAAK","label":"Troubleshooting->Planning Analytics For Excel"}],"ARM Case Number":"TS003887160","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
07 July 2020
UID
ibm16244652