Troubleshooting
Problem
User launches Controller classic client (CCR.EXE). User chooses database. Because the customer has implemented 'Windows Authentication (direct)' authentication (which includes single sign-on), the user is not prompted to logon.
The Controller classic client successfully appears. However, problems/errors occur during the use of Controller client, triggered by the fact that the configuration file ("ccr.config" in the end user's Windows user profile) does not contain sufficient information.
Symptom
Imagine a scenario where the end user has a brand-new Windows user profile (or has never launched Controller client on their PC before). After the first time of launching Controller client, below are two examples of their ccr.config files:
Example #1 (Windows Authentication - direct):
<configuration>
<configSections>
<sectionGroup name="profile">
<section name="Settings" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, Custom=null" />
</sectionGroup>
</configSections>
<profile>
<Settings>
<add key="CASUrl" value="C:\Program Files\IBM\IBM Cognos Controller Local Client\" />
<add key="WSSUrl" value="http://WIN19S-CCR1042.mydomain.mycompany.com/ibmcognos/controllerserver" />
<add key="HelpUrl" value="http://www.ibm.com/support/knowledgecenter" />
<add key="VerNo" value="10.4.2000.252" />
<add key="SelectDb" value="True" />
<add key="Language" value="2057" />
<add key="LastDb" value="Blank" />
</Settings>
</profile>
</configuration>
<configSections>
<sectionGroup name="profile">
<section name="Settings" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, Custom=null" />
</sectionGroup>
</configSections>
<profile>
<Settings>
<add key="CASUrl" value="C:\Program Files\IBM\IBM Cognos Controller Local Client\" />
<add key="WSSUrl" value="http://WIN19S-CCR1042.mydomain.mycompany.com/ibmcognos/controllerserver" />
<add key="HelpUrl" value="http://www.ibm.com/support/knowledgecenter" />
<add key="VerNo" value="10.4.2000.252" />
<add key="SelectDb" value="True" />
<add key="Language" value="2057" />
<add key="LastDb" value="Blank" />
</Settings>
</profile>
</configuration>
Example #2 (Native authentication):
<configuration>
<configSections>
<sectionGroup name="profile">
<section name="Settings" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, Custom=null" />
</sectionGroup>
</configSections>
<profile>
<Settings>
<add key="CASUrl" value="C:\Program Files\IBM\IBM Cognos Controller Local Client\" />
<add key="WSSUrl" value="http://WIN19S-CCR1042.mydomain.mycompany.com/ibmcognos/controllerserver" />
<add key="HelpUrl" value="http://www.ibm.com/support/knowledgecenter" />
<add key="VerNo" value="10.4.2000.252" />
<add key="SelectDb" value="True" />
<add key="Language" value="2057" />
<add key="LastDb" value="Blank" />
<add key="LastUser" value="ADM" />
</Settings>
</profile>
</configuration>
<configSections>
<sectionGroup name="profile">
<section name="Settings" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, Custom=null" />
</sectionGroup>
</configSections>
<profile>
<Settings>
<add key="CASUrl" value="C:\Program Files\IBM\IBM Cognos Controller Local Client\" />
<add key="WSSUrl" value="http://WIN19S-CCR1042.mydomain.mycompany.com/ibmcognos/controllerserver" />
<add key="HelpUrl" value="http://www.ibm.com/support/knowledgecenter" />
<add key="VerNo" value="10.4.2000.252" />
<add key="SelectDb" value="True" />
<add key="Language" value="2057" />
<add key="LastDb" value="Blank" />
<add key="LastUser" value="ADM" />
</Settings>
</profile>
</configuration>
~~~~~~~~~~~~~~~~~~~~~~~~~~
As you can see above, the 'Windows Authentication' version is missing some crucial configuration information, specifically "LastUser"
- This causes issues/errors such as seen in separate IBM Technote #6243454.
~~~~~~~~~~~~~~~~~~~~~~~~~~
Cause
Defect (APAR PH27135) in Controller 10.4.2.
Resolving The Problem
Fix:
Upgrade to a future version of Controller, which solves this problem.
- TIP: To be automatically notified when this version is available, subscribe to APAR PH27135.
Workaround:
Manually add an entry for 'LastUser' into the end user's file "ccr.config"
Steps:
1. Logon to the device where the Controller client is installed (for example end user's laptop, or Citrix server)
2. Ensure that the 'bad' end user is not currently running Controller client
3. Browse to the end user's Windows user profile
- TIP: By default this is here: C:\Users\<username>\AppData\Roaming
4. Open the subfolder: Cognos
5. Open the subfolder: CCR
6. Open the file ccr.config in NOTEPAD
7. Add a line similar to the following, underneath the entry for "LastDb" so it looks similar to:
<add key="LastDb" value="Blank" />
<add key="LastUser" value="ADM" />
<add key="LastUser" value="ADM" />
NOTE: Modify the value 'ADM' to be the correct Controller username (which may be different from the Windows username) of the end user.
8. Save changes and test.
Related Information
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"ARM Category":[{"code":"a8m50000000KzLjAAK","label":"Logon Issues"}],"ARM Case Number":"TS003756597","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"10.4.x","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
31 July 2020
UID
ibm16243458