Troubleshooting
Problem
Catalogs > All catalogs is not accessible and getting error "Redis store is not available"
Symptom
Cause
The dc-main app failed to access the redis-ha-proxy.
Diagnosing The Problem
Check the dc-main pod
oc describe pod $(oc get pods | grep dc-main | awk '{print $1 }' )
oc logs $(oc get pods | grep dc-main | awk '{print $1 }' )
Also, check the redis-ha-server pod
oc describe pod $(oc get pods | grep redis-ha-server-0 | awk '{print $1 }' )
oc logs redis-ha-server-0 -c redis
Resolving The Problem
Step 1: Restart the redis-ha-server, redis-ha-haproxy, dc-main, portal-main, portal-dashboard, and portal-catalog pods.
Restart the redis-ha-server pods by scale the redis-ha-server statefulset.
oc scale --replicas=0 sts redis-ha-server
oc scale --replicas=3 sts redis-ha-server
Restart the redis-ha-haproxy pod
oc delete pods $(oc get pods | grep redis-ha-haproxy | awk '{ print $1 }' )
Restart the dc-main pod
oc delete pods $(oc get pods | grep dc-main | awk '{print $1 }' )
Restart the portal-main pod
oc delete pods $(oc get pods | grep portal-main | awk '{print $1 }' )
Restart the portal-dashboard pod
oc delete pods $(oc get pods | grep portal-dashboard | awk '{print $1 }' )
Restart the portal-catalog pod
oc delete pods $(oc get pods | grep portal-catalog | awk '{print $1 }' )
Step 2: Restart the nginx pods
oc scale --replicas=0 deployment ibm-nginx
oc scale --replicas=3 deployment ibm-nginx
Step 3: Log out and log in to Cloud Pak for Data web console. You will be able to the access Catalogs > All catalogs.
After you fix the issue above,
- if you are unable to open Notebook with the error "Failed to load notebook", try: https://www.ibm.com/support/pages/node/6453291
- if you are unable to see jobs with the error "Something's wrong, but we are trying to fix it", try: https://www.ibm.com/support/pages/node/6454001
Document Location
Worldwide
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Document Information
Modified date:
21 August 2023
UID
ibm16238158