IBM Support

IBM License Metric Tool の管理対象の新規コンピューターが BigFix コンソールに表示されない

Troubleshooting


Problem

IBM License Metric Tool の管理対象として、BigFix クライアントをインストールしましたが、BigFix コンソール上のコンピューター一覧に表示されません。

 

Cause

BigFix クライアントのインストールが完了すると、通常は接続先 BigFix サーバーへの接続が行われ、BigFix コンソール上のコンピューター一覧に表示されます。
BigFix コンソールに新規クライアントが表示されない場合は、以下を確認する必要があります。

Resolving The Problem

1. クライアントからサーバーへのネットワーク接続は可能か
 
BigFix クライアントは、BigFix サーバーに対して 52311 ポートで接続可能である必要があります。 
 
<コマンドによる確認>
 
以下のようなコマンドで、クライアントからサーバーへの接続を確認できます。クライアント側で実行して結果をご確認ください。
 
1) ping <Server> 
2) telnet <Server> 52311 
3) Test-NetConnection <Server> -Port 52311
4) nc -vz <Server> 52311
 
- <Server> の部分に BigFix サーバーの IP アドレスを指定した場合とホスト名を指定した場合を確認します。
- 3) は Windows 環境で利用可能です。
- 4) は Linux 環境で利用可能です。
  
<ブラウザによる確認>
 
クライアント側でブラウザを起動して下記 URL を開きます。
 
https://<Server>:52311/data/login
 
- <Server> の部分に BigFix サーバーの IP アドレスを指定した場合とホスト名を指定した場合を確認します。
- ログイン画面が表示されるので、BigFix サーバー接続用ユーザー (IEMAdmin 等) としてログインできるかどうかを確認します。
  
2. クライアントのバージョンがサーバーのバージョンよりも高くないか
 
BigFix クライアントのバージョンが BigFix サーバーよりも高い環境はサポートされていません。このようなバージョンの組み合わせでは、クライアントからサーバーへの接続が失敗することがあります。
サーバーよりも高いバージョンの BigFix クライアントが導入されている場合は、その BigFix クライアントをアンインストールして、BigFix サーバーと同じか、それよりも低いバージョンのクライアントをインストールしてください。
 
ILMT 環境のバージョン確認方法
  
3. クライアントの再起動
 
以下の BigFix クライアント・サービスが稼働しているかどうかをご確認ください。
  
Windows:      BES Client
RHEL/SLES:  besclient
AIX:             SBESClientd
  
稼働していない場合はサービスの起動を行ってください。
また、稼働しているように見える場合でも正常に動作していない可能性があります。
一旦停止した後で起動し、BigFix コンソールに表示されるようになるかどうかをご確認ください。
 
BigFixクライアントの起動・停止方法
 
4. 正しい手順でクライアントをインストールしたか
 
BigFix クライアントが正常に動作するためには正しいマスヘッドファイルが必要です。
マスヘッドファイルには BigFix サーバーへの接続情報が記述されているためです。
下記マニュアルに従ってインストールされなかった場合、マストヘッドファイルが正しく導入されていないためにクライアントからサーバーへの接続が失敗することがあります。
 
Installing the client manually on Windows systems
※ Windows 環境の場合はこちらをご参照ください。
  
Installing the Client Manually
※ Windows 以外の場合は、こちらから該当する環境を選択してご参照ください。

Document Location

Worldwide

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Document Information

Modified date:
26 April 2021

UID

ibm16236908