IBM Support

Windows unzip prompts for password trying to unzip disk image

Troubleshooting


Problem

If you download a disk image file from Passport Advanatage or Extreme Leverage download sites onto a Windows Platform such as Windows XP or Server 2003 and use the native unzip utility to unzip the file the unzip will pause with a prompt for a password on a file or directory within the compressed file. This prevents the succesful completion of the unzip process. Selecting Cancel on the prompt will allow the unzip to proceed, but some files may be missing in the resulting unzip folder which may affect the installation of products contained in the unzipped install files.

Symptom

The unzip pauses with a prompt for a password for a file or directory within the zip file.

Cause

It is an issue with filename/path length in the resultant unzipped directories but why it shows up as a password prompt is unknown at this time.

Diagnosing The Problem

Example:
Install files are located on a machine at:
C:\Documents and Settings\Administrator\My Documents\Install Files\WAS61 which is already a long path. The install files for the supplemental disk also have a long path for the files that caused the password prompts:

InstallationFactory/eclipse/plugins/com.ibm.ws.install.factory.was.cip.v
61_6.1.0/mergeengine/data/OpenInstallImage/was.primary.pak/repository/ni
f.componentmap.primary

So combined it was trying to unzip to:
C:\Documents and Settings\Administrator\My Documents\Install
Files\WAS61\InstallationFactory/eclipse/plugins/com.ibm.ws.install.facto
ry.was.cip.v61_6.1.0/mergeengine/data/OpenInstallImage/was.primary.pak/repository/ni
f.componentmap.primary

This is beyond the Windows path length limit.

When the path to unzip the files to was shortened then there were no prompts for password and the extract proceeded as expected.

Resolving The Problem

When the unzip utility starts it offers a default path and directory to unzip the files to. Try changing the path length to perhaps unzip to root (i.e. c:\C88UXML). If this is successful experiment with how much path from root can be included. If you try to cut and paste the unzipped install folder to the original subdirectory path that was too long you will be unable to access the files that had caused the password prompt and will get a path length error.

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Install","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0;6.1;6.0","Edition":"Advanced;Base;Developer;Enterprise;Express;Feature Pack for EJB 3.0;Feature Pack for SCA;Feature Pack for Web 2.0;Feature Pack for Web Services;Network Deployment;Single Server;WebSphere Business Integration Server Foundation","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21378370