Troubleshooting
Problem
TM1 Admin server fails to start. The service starts and immediately stops again.
Symptom
TM1 Admin server log (/tm1_64/bin64/tm1admsvr.log) gets updated with the following entries when the Admin server fails to startup
2920 ERROR 2020-06-08 17:31:46,998 TM1.Comm.SSL gsk_environment_init failed. Error: 408
2920 ERROR 2020-06-08 17:31:46,998 TM1.TM1AdmSvr GSK environment initialization failed
2920 ERROR 2020-06-08 17:31:46,998 TM1.TM1AdmSvr GSK environment initialization failed
Cause
The issue could be caused due to the following reasons
- Incorrect path specified for the 'Key database location' and the 'Key database passwords location' parameters within Cognos configuration.
- Service account configured to run the "IBM Cognos TM1 Admin Server x64" service does not have permissions to access the key database password location (Ex : custom.sth, ibmkdb.sth), example below:
Resolving The Problem
- Ensure that the path specified for "key database location" and "key database password location" in Cognos Configuration is correct.
- Ensure the Account configured to run the "IBM Cognos TM1 Admin Server x64" has at least "READ" permissions over the "key database password location" (Ex: custom.sth)
Related Information
Document Location
Worldwide
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Document Information
Modified date:
11 June 2020
UID
ibm16224520