IBM Support

Planning Analytics Secure Gateway every 2nd connection attempt to the database fails

Troubleshooting


Problem

Using the Secure Gateway Client to connect from your cloud Planning Analytics environment to an on-premise database, you will see every 2nd connection attempt to the database fails.

Cause

More than one Secure Gateway Client is connected to the environment at the same time, and one of these machines is not able to connect to the database host (either by design or due to misconfiguration). When 2 clients are connected to the Secure Gateway Server the connections to the database will follow a round robin behaviour between the 2 client installs. If one client cannot connect to the database, then every 2nd connection attempt will fail.

Resolving The Problem

First you will need to identify if the additional Secure Gateway Client connection is expected or not.
If it is, review the configuration so you can make a successful connection to the database.
If it is not, and you are not sure where the connection is coming form, you can regenerate a new token in the Planning Analytics Workspace Secure Gateway page and update your Secure Gateway Client configuration. This will invalidate any other client connection not using the updated token. You can also raise a case with the Planning Analytics support team and we can provide information on other connections using the same gateway ID. This will likely point you to an additional machine in your network that has a forgotten client install.

Document Location

Worldwide

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Document Information

Modified date:
20 September 2021

UID

ibm16217543