IBM Support

Planning Analytics Workspace: Docker Service not starting in Services

Troubleshooting


Problem

Docker is a pre-requisite for Planning Analytics Workspace. If the Docker service does not start, you will not be able to start Planning Analytics Workspace. 
This issue talks about the Docker service being unable to start through Services (services.msc). 

Symptom

Event Viewer
In Windows Event Viewer, you'll see error logs under System which state "The Docker Engine service terminated unexpectedly. It has done this [x] time(s)." 
Powershell
1. Running start-service docker will give you the following error:
start-service: Failed to start service 'Docker Engine (docker)'.
2. Running net start docker will give you the following error:
The Docker Engine service is starting.
The Docker Engine service could not be started.
More help is available by typing NET HELPMSG 3523

Cause

An application is conflicting with Docker which prevents it from starting up e.g. Antivirus or Application Monitoring Apps such as Dynatrace Agent

Resolving The Problem

Uninstall any potential conflicting applications (e.g. Antivirus, Dynatrace Agent) to confirm whether this is the cause and re-test. 
Depending on your software, you may need to reach out to both Docker and the software vendor to confirm whether they are compatible. 

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
21 September 2021

UID

ibm16217316