Troubleshooting
Problem
In the Log Activity tab in the QRadar® UI, a pop-up window displayed an error message: Client Exception - The following client exception occurred while handling the server response: {0} SyntaxError: Invalid or unexpected token.
Symptom
A Client Exception message might be displayed similar to:
Note: When a similar pop-up message occurs, log activity works as expected after closing the message.
Cause
An authorized service token created in an older version of QRadar and used for API resources might cause the client exception
popup to be displayed.
Environment
QRadar 7.3.2 and later.
Resolving The Problem
To avoid unnecessary authorized service tokens for APIs resources access if they are not longer needed.
- Log in to the QRadar user interface as admin user.
- Click Admin tab.
- Click Authorized Services.
- Select the Service Name.
- Click Delete.
Important: Deploying Changes will result in services being restarted. While services are restarting, users might loose access until services restart. Administrators with strict outage policies are advised to complete the next step during a scheduled maintenance window for their organization. - Click Admin tab > Deploy Changes.
Results
The Client Exception pop-messages are no longer displayed.
Document Location
Worldwide
[{"Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"ARM Category":[{"code":"a8m0z000000cwtEAAQ","label":"Log Activity"}],"ARM Case Number":"","Platform":[{"code":"PF016","label":"Linux"}],"Version":"7.3.2;7.3.3;7.4.0;7.4.1"}]
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Document Information
Modified date:
28 August 2020
UID
ibm16214605