IBM Support

Cognos Analytics 11.1.6 – 404 Error when attempting to log into a second namespace through IIS gateway

Troubleshooting


Problem

After an upgrade to 11.1.6, users can run into a 404 error when attempting to log into a second namespace when accessing the environment via the gateway using the IIS web server. The issue does not occur directly through the dispatcher URI.

Cause

The IIS configuration needs to be updated using the script supplied with 11.1.6. As newer versions of Cognos Analytics are released, changes can be made to the web server configuration. It is advised that users should always use the latest version of the script which can be found in the install directory under: cognos_install\cgi-bin\templates\IIS.

Resolving The Problem

  1. Follow this technote to clear out current IIS configuration –
    https://www.ibm.com/support/pages/how-properly-clear-microsofts-internet-information-service-iis-configurations-setup-new-configuration-iis-support-ibm-cognos
  2. Navigate to cognos_install\cgi-bin\templates\IIS and modify the .bat file with a text editor to match your environment variables. Only modify the following variables found on this page –
    https://www.ibm.com/support/pages/automate-configuration-microsofts-internet-information-service-support-ibm-cognos-analytics
  3. Run the script to configure IIS once again.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl6iAAC","label":"Installation and Configuration->Gateway"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
22 May 2020

UID

ibm16214487