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Unable to install or edit Policies after upgrading to v10.6 patch p640

Troubleshooting


Problem

You have just applied patch p640 to the Central Manager (CM) and you can no longer install a policy on a collector.  You get the message "Operation could not complete due to a database error."

Cause

Patch p640 adds a schema change.  This error is due to a schema mismatch between the CM and the collectors. 

Environment

CM is at v10.6 patch p640 and collectors are at a lower version. 

For mixed environments, e.g. CM is at version 11 and collectors are at a version 10 version lower than patch p640, this error can also occur.  To resolve the problem in that case, upgrade the Central Manager to v11.1 patch p106.

Diagnosing The Problem

If the issue is reproduced with the application debugger, a stack similar to this appears in the debug-log:
==============Wed May 06 12:17:54 COT 2020===================
Thread: http-bio-8443-exec-9 - com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Unknown column 'ACCESS_RULE.ACTIVE_ANALYTIC_THRESHOLD' in 'field list'
	at sun.reflect.GeneratedConstructorAccessor92.newInstance(Unknown Source)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:57)
...

Resolving The Problem

Upgrade all collectors to patch 640.  

If the Central Manager is at version 11, upgrade the CM to patch level 11.1 p106.  This patch also has the schema change.

Document Location

Worldwide

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Document Information

Modified date:
21 May 2020

UID

ibm16213269