IBM Support

Incident ID is not in sequence

Troubleshooting


Problem

When you create a new incident, the Incident ID is not in sequence.

Symptom

Action Incident ID
Create 1000
Create
1001
Create 1010
Create 1011
Note that there is a gap of incidents IDs in the range 1001 - 1010.

Cause

The Incident ID field is a global field that is:
* For any incident, regardless of Org, the next ID value is assigned.
* If an incident fails to create, the transaction is rolled back but the assigned ID is not.
* If other users have a pending 'draft' in the Incident Creation wizard, this draft is still assigned an incident ID.
Org Action ID
OrgA Create 1200
OrgB Create 1201
OrgA Create (Fail) 1202
OrgA Create 1203

Resolving The Problem

 Designed to work as expected.

There is a feature called incident sequence code field. This added a Sequence Code incident field that you use to sequentially number the incidents within a Resilient organization. For more details, go to the following documentation:
https://www.ibm.com/docs/en/sqsp/51?topic=organization-settings

Document Location

Worldwide

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Document Information

Modified date:
24 January 2024

UID

ibm16212161