Troubleshooting
Problem
An IBM Spectrum Protect server database restore may fail with DB2 sqlcode -2079
Symptom
The "dsmserv restore db" command fails with the following error :
ANR2971E Database backup/restore/rollforward terminated - DB2 sqlcode -2079
The db2diag.x.log file shows the following error :
<timestamp> xxxxx LEVEL: Error
PID : xxx TID : yyy PROC : db2syscs.exe
INSTANCE: SERVER1 NODE : 000 DB : TSMDB1
APPHDL : x-x APPID: *LOCAL.SERVER1.200514172031
AUTHID : TSMINST HOSTNAME: HOST
EDUID : xxx EDUNAME: db2med.5080.0 (TSMDB1)
FUNCTION: DB2 UDB, database utilities, sqluMapVend2MediaRCWithLog, probe:nnn
DATA #1 : String, 141 bytes
Vendor error: rc = 30 returned from function sqluvint.
Return_code structure from vendor library C:\PROGRA~1\Tivoli\TSM\db2\bin\db2tsm.dll:
PID : xxx TID : yyy PROC : db2syscs.exe
INSTANCE: SERVER1 NODE : 000 DB : TSMDB1
APPHDL : x-x APPID: *LOCAL.SERVER1.200514172031
AUTHID : TSMINST HOSTNAME: HOST
EDUID : xxx EDUNAME: db2med.5080.0 (TSMDB1)
FUNCTION: DB2 UDB, database utilities, sqluMapVend2MediaRCWithLog, probe:nnn
DATA #1 : String, 141 bytes
Vendor error: rc = 30 returned from function sqluvint.
Return_code structure from vendor library C:\PROGRA~1\Tivoli\TSM\db2\bin\db2tsm.dll:
Cause
Incorrect installation of Spectrum Protect Backup-client API and GSKit level.
Environment
IBM Spectrum Protect server 7.1.9.0 on Windows 2012
Diagnosing The Problem
Verify the level of the Spectrum Protect (TSM) Backup-Archive client in "Programs and Features" in the Windows control panel.
Then, verify the level of the following files :
c:\windows\system32\tsmapi64.dll
c:\windows\system32\tsmutil164.dll
c:\windows\system32\dsmntapi64.dll
c:\windows\system32\tsmutil164.dll
c:\windows\system32\dsmntapi64.dll
From Windows explorer, right click on the file and select properties.
View the level in the details tab.
View the level in the details tab.
It should match the level of the client from the control panel. In this case, the levels did not match.
Resolving The Problem
It is necessary to uninstall and reinstall the Spectrum Protect client API using the following steps.
- Uninstall the Spectrum Protect Backup-Archive client
- Delete C:\Program Files\Common Files\Tivoli\TSM\api64
- Delete c:\windows\system32\tsmapi64.dll
- Delete c:\windows\system32\tsmutil164.dll
- Delete c:\windows\system32\dsmntapi64.dll
- reboot
- Reinstall the Spectrum Protect Backup-Archive client.
It is important to install the same level of the client that was used for the database backup.
There are different levels of GSKIT provided with different levels of the client which can cause a GSKIT library load failure.
For example, in this case the backup was done with the 7.1.8.2 client level installed but the restore was attempted with the 7.1.8.0 client. This caused the error on with the database restore.
Document Location
Worldwide
[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSEQVQ","label":"IBM Spectrum Protect"},"ARM Category":[],"Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.1.9","Line of Business":{"code":"LOB26","label":"Storage"}}]
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Document Information
Modified date:
21 May 2020
UID
ibm16209660