IBM Support

Can JazzSM server be backup and restore using these scripts-backupConfig.sh and restoreConfig.sh?

Question & Answer


Question

Can you back up and restore the JazzSM installation using the backupConfig.sh and restoreConfig.sh that are available in these paths
/opt/IBM/WebSphere/AppServer/bin
/opt/IBM/JazzSM/profile/bin

Cause

If you had tried to perform these steps on your JazzSM server after running the backupConfig.sh command.
  [root@test-jazzsm bin]# ./restoreConfig.sh WebSphereConfig_2020-05-10.zip    ADMU0116I: Tool information is being logged in file               /opt/IBM/JazzSM/profile/logs/restoreConfig.log    ADMU0128I: Starting tool with the JazzSMProfile profile    ADMU0505I: Servers found in configuration:    ADMU0506I: Server name: server1    ADMU2010I: Stopping all server processes for node JazzSMNode01    ADMU0512I: Server server1 cannot be reached. It appears to be stopped.    ADMU5502I: The directory /opt/IBM/JazzSM/profile/config already exists;               renaming to /opt/IBM/JazzSM/profile/config.old    ADMU5504I: Restore location successfully renamed    ADMU5505I: Restoring file WebSphereConfig_2020-05-10.zip to location               /opt/IBM/JazzSM/profile/config     
It will successfully restore the WebSphere but will corrupted the JazzSM files and causing the JazzSM login URL not to be working although JazzSM server process can be started.
A deeper investigation had found that , the Installation Manager version is showing 3.1.3.6 while the Consolecli.sh Version still showing the older version 3.1.3.0
image 3457

         

If you had ran the backupConfig.sh and restoreConfig.sh on your JazzSM server and is not able to login as the screen captures above, you will need to uninstall the 3136 version using Installation Manager and reinstall the DASH 3136 again.

 

Answer

It is strongly not recommended to use these scripts for performing backup and restore procedure on JazzSM.
But you can back up the following folders before any major changes that you need to perform on your server, these are default folders so you may need to change according to your environment:
  1. WebSphere Application folder = /opt/IBM/WebSphere

  2. JazzSM folder = /opt/IBM/JazzSM

  3. Installation Manager Agent Data = /var/ibm/InstallationManager

  4. IMShared = /opt/IBM/IMShared

  5. Installation Manager directory (optional) = /opt/IBM/InstallationManager/

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSEKCU","label":"Jazz for Service Management"},"ARM Category":[{"code":"a8m50000000L2v1AAC","label":"JazzSM->Administration"}],"ARM Case Number":"TS003685939","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"All Version(s)","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

JazzSM, backupConfig.sh, restoreConfig.sh

Document Information

Modified date:
26 May 2020

UID

ibm16208909