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Can not login to TM1 server from Perspectives, (N33) Connection Failed occur.

Troubleshooting


Problem

Since accessing TM1 server through VPN, some user encounter (N33) Connection Failed error when connect.
This is intermittent issue.

Symptom

Steps to reproduce
(1) Opening the Perspectives file from share folder using VPN connection
(2) Click Enable content
(3) Click "Connect"
(4) It takes a few minutes to see TM1 server list, and then select TM1 server
(5) N33) Connection Failed occur

Cause

Perspective could reach to TM1 Admin server but could not reach to TM1 Server in TCP/IP level through VPN.

Diagnosing The Problem

Execute following command to check network status.
netstat -anob
Result (selecting TM1 server)
TCP     <Client IP>:58871  <Server IP>:8080  TIME_WAIT    0  -> TM1 Admin server has finished connection
 TCP     <Client IP>:58875  <Server IP>:<TM1 port>   SYN_SENT    24648  -> Connection request has sent to TM1 server and waiting for response
Second line status should be TIME_WAIT or ESTABLISHED

Resolving The Problem

Check all of VPN server configuration which enable to access <Server IP>:<TM1 port>.

Document Location

Worldwide

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Document Information

Modified date:
07 May 2020

UID

ibm16207748