Question & Answer
Question
After upgrading to Log Analysis 1.3.6, and running `unity.sh -status`, why do I get:
CTGLA0014E : Error initializing flow controller
the UnityApplication.log shows:
Caused by: javax.net.ssl.SSLHandshakeException: Server chose TLSv1, but that protocol version is not enabled or not supported by the client.
Cause
When upgrading to LA 1.3.6, using the Solr SSL LDAP implementation forces the use of 'TLSv1'
Answer
This behaviour is being tracked by APAR IJ2442 as a workaround, in file
<HOME>/IBM/LogAnalysis/wlp/usr/servers/Unity/server.xml
find under LDAPSSLSettings the entry:
sslProtocol="TLSv1.2"
change it to
sslProtocol="TLSv1"
restart LA:
sslProtocol="TLSv1.2"
change it to
sslProtocol="TLSv1"
restart LA:
<HOME>/IBM/LogAnalysis/utilities/unity.sh -restart
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSPFMY","label":"IBM Operations Analytics - Log Analysis"},"ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB45","label":"Automation"}}]
Historical Number
TS003546346
Was this topic helpful?
Document Information
Modified date:
07 February 2023
UID
ibm16206147