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VFP and VFPCOM error messages when installing Controller server, causing frangoVFP.dll not to be registered in Component Services (COM+), caused by APAR PH24802

Troubleshooting


Problem

Administrator installs Controller server software. Afterwards, administrator opens the log folder (default: C:\Program Files\ibm\cognos\ccr_64\instlog) and reads the installation log file (for example "tl-CNTRL-10.4-2000.185-20200416_0857.txt").
  • There are several errors in there.
Afterwards, user tries to use some functionality (for example run a consolidation) which relies on the frangovfp.dll COM+ component.
  • This functionality fails.
To troubleshoot it, the administrator opens Component Services, and notices that the FrangoVFP.dll component has not successfully registered.

Symptom

Install component: VFP 
Component Version: VFP-AW64-ML-RTM-9.0.2120.0 
File "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\server\vfp9r.dll" successfully extracted.
File "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\server\vfp9renu.dll" successfully extracted.
File "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\server\vfp9t.dll" successfully extracted.
File "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\vers\vfp-winx64h-app-9.0.2120.0-inst.ver" successfully extracted.
File "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\vers\vfp-winx64h-app-inst.ver" successfully extracted.
Successfully created directory "C:\Windows\system32\server\".
Successfully copied file "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\server\vfp9r.dll" to file "C:\Windows\system32\server\vfp9r.dll".
Self registration of file using command line "C:\Windows\system32\regsvr32.exe  /s "C:\Windows\system32\server\vfp9r.dll"".
Error: Failed system command "C:\Windows\system32\regsvr32.exe  /s "C:\Windows\system32\server\vfp9r.dll"".
Error: Application has returned exit code "3". 

Successfully deleted file "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\server\vfp9r.dll".
Successfully set value "C:\Windows\system32\server\vfp9r.dll" for key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs".
Successfully copied file "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\server\vfp9renu.dll" to file "C:\Windows\system32\server\vfp9renu.dll".
Self registration of file using command line "C:\Windows\system32\regsvr32.exe  /s "C:\Windows\system32\server\vfp9renu.dll"".
Error: Failed system command "C:\Windows\system32\regsvr32.exe  /s "C:\Windows\system32\server\vfp9renu.dll"".
Error: Application has returned exit code "4". 

Successfully deleted file "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\server\vfp9renu.dll".
Successfully set value "C:\Windows\system32\server\vfp9renu.dll" for key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs".
Successfully copied file "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\server\vfp9t.dll" to file "C:\Windows\system32\server\vfp9t.dll".
Self registration of file using command line "C:\Windows\system32\regsvr32.exe  /s "C:\Windows\system32\server\vfp9t.dll"".
Error: Failed system command "C:\Windows\system32\regsvr32.exe  /s "C:\Windows\system32\server\vfp9t.dll"".
Error: Application has returned exit code "3". 

Successfully deleted file "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\server\vfp9t.dll".
Successfully set value "C:\Windows\system32\server\vfp9t.dll" for key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs".
Successfully deleted file "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\vers\vfp-winx64h-app-9.0.2120.0-inst.ver".
Successfully deleted file "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\vers\vfp-winx64h-app-inst.ver".
Successfully added value "1" for key "VFP" under section "Component List" in file "C:\Program Files\ibm\cognos\ccr_64\uninstall\uninst.ini".
Install component: VFPCOM 
Component Version: VFPCOM-AW64-ML-RTM-9.0.2123.0 
File "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\server\vfpcom.dll" successfully extracted.
File "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\vers\vfpcom-winx64h-app-9.0.2123.0-inst.ver" successfully extracted.
File "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\vers\vfpcom-winx64h-app-inst.ver" successfully extracted.
Successfully copied file "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\server\vfpcom.dll" to file "C:\Windows\system32\server\vfpcom.dll".
Self registration of file using command line "C:\Windows\system32\regsvr32.exe  /s "C:\Windows\system32\server\vfpcom.dll"".
Error: Failed system command "C:\Windows\system32\regsvr32.exe  /s "C:\Windows\system32\server\vfpcom.dll"".
Error: Application has returned exit code "3". 

Successfully deleted file "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\server\vfpcom.dll".
Successfully set value "C:\Windows\system32\server\vfpcom.dll" for key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs".
Successfully deleted file "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\vers\vfpcom-winx64h-app-9.0.2123.0-inst.ver".
Successfully deleted file "C:\Users\ADMINI~1\AppData\Local\Temp\2\COG_2\vers\vfpcom-winx64h-app-inst.ver".
Successfully added value "1" for key "VFPCOM" under section "Component List" in file "C:\Program Files\ibm\cognos\ccr_64\uninstall\uninst.ini".
Component Services:
There are no components inside 'IBM Cognos Controller Consolidation':
image 3011

Cause

Defect (reference APAR PH24802) in Controller.

Environment

Problem has been seen with Controller 10.4.2 RTM.
  • However, it has also been seen with earlier versions (for example 10.4.1).

Resolving The Problem

Fix:
Upgrade to a future version of Controller (when released) which contains a fix for defect APAR PH24802.
  • TIP: To be automatically notified when this version is available, subscribe to APAR PH24802.
  
Workaround:
In some cases (for example when this is an upgrade from a previous version of Controller), the error (in the log file) is benign.
  • Therefore you can sometimes ignore those messages.
However, in some cases (for example a brand-new installation on a brand-new Windows server), there has been a problem registering the COM+ (VFP) files, which means that several pieces of functionality (for example consolidations) will not work.
  • In this scenario, you should manually re-register the VFP and COM+ components.
Steps to manually re-register the VFP and COM+ components:
TIP: For more details (including printscreens) see separate IBM Technote #374767.
1. Logon to your Controller application server as a Windows administrator
2. Check that the following file exists: C:\windows\SysWOW64\msvcr71.dll
If not, then:
  • Browse to this folder: C:\Program Files\IBM\cognos\ccr_64\server
  • Copy the file msvcr71.dll into this folder: C:\windows\SysWOW64
3. Check that the following 4 files exist inside C:\Windows\SysWOW64\server:
  • vfp9r.dll
  • vfp9renu.dll
  • vfp9t.dll
  • vfpcom.dll
3. Launch a command prompt, by right-clicking on the 'Start' button and choosing 'Command Prompt - Admin"
4. Type the following: 
cd c:\windows\syswow64\server
REGSVR32 VFPCOM.DLL 
image 3012
  
5. Type the following:
regsvr32 vfp9r.dll
regsvr32 vfp9t.dll
6. Click 'Start - Windows Administrative Tools - Component Services' 
  • Alternatively, launch the following: %windir%\system32\comexp.msc
7. Expand 'Computers - My Computer - COM+ Applications - IBM Cognos Controller Consolidation - components' 
  • It is possible that there is currently nothing in there (it is empty)
8. Right-click on 'Components' and choose 'New - Component'
9. Click Next
10. Click 'Install New Components'
11. Browse to: "C:\Program Files\IBM\cognos\ccr_64\server\frangovfp.dll
12. Click Next
13. Click Finish 
  • The screen should now look similar to:
image 3010
14. Test.

Document Location

Worldwide

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Document Information

Modified date:
27 April 2020

UID

ibm16198780