IBM Support

Images not appearing in IBM Cognos PDF reports when using HTTPS

Troubleshooting


Problem

Report images do not appear in Cognos reports if the images are stored on an SSL-enabled web server. The images render fine in HTML but not in PDF or Excel

Symptom

In place of the image, a blank box appears in the report.

Cause

The Webserver certificates need to be imported into Cognos

Resolving The Problem

To resolve this issue:
  1. Download the Certificates from the image WebServer
     
  2. Import the CA certificate that is used to enable SSL for the web server into IBM Cognos.

    For more information about importing certificates into the IBM Cognos, see the following page: https://www.ibm.com/support/pages/how-add-3rd-party-ca-allow-ssl-between-components-ibm-cognos-analytics-11

    You can use the following commands
    ThirdPartyCertificateTool.bat -i -T -r root.cer -p NoPassWordSet
    ThirdPartyCertificateTool.bat -i -T -r intermediate.cer -p NoPassWordSet
    ThirdPartyCertificateTool.bat -i -T -r server.cer -p NoPassWordSet
     
  3. Change the conformance of your IBM Cognos from NIST SP 800-131A to IBM Cognos.
    To do this, on the Cognos Configuration tool, Navigate to Security >> Cryptography >>

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"","label":""}],"Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
21 April 2020

UID

ibm16195437