IBM Support

XQE-ROL-0237 in a Multi-Server Environment for Cognos Analytics

Question & Answer


Question

User gets the following error when attempting to run a Cognos Admin task in a Multi-server enironment
XQE-ROL-0237 Conversation ID 'xxx' not found when executing request

Cause

Query Service is processing Wait Request before Actual Request

Answer

Update the queryService.xml file to replace with the FQDN of your servers. Follow the steps below:

 

On each install:

 

1) Stop your Cognos services

2) Get value for hostName from configuration/dispatcher.properties or from running dispatcher command line. It looks like FQDN (fully quailified). Example: server.domain.com

3) Edit the webapps/p2pd/WEB-INF/services/queryService.xml file

4) Add the following line in bold to the file:

 

    <handler name="queryServiceHandler" classname="com.cognos.xqebifw.cubingservices.CubingServicesHandler" ...>

      <target>

         <child-proc-cmd>-Djava.rmi.server.hostname=hostname_from_item_2</child-proc-cmd>

         

4) Restart Cognos

 

This will need to be done on all servers that have the dispatcher component and the QueryService enabled.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl3zAAC","label":"Administration"}],"ARM Case Number":"","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"11.0.x, 11.1.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
22 April 2020

UID

ibm16195424