Troubleshooting
Problem
In IBM Security Guardium™, the fileserver facility is used to ease tasks like uploading patches files to the appliance or downloading application logs and other diagnostic and configuration files, by temporarily running an HTTP (S) file server.
Sometimes, when trying to start the fileserver from the command line interface (CLI), an error message is displayed.
Fileserver is already running.
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Symptom
Unable to start the fileserver.
When running the "fileserver" command to start the service, the error message is displayed.
Cause
This component uses a special lock file (something like a "padlock") to avoid having more than one instance of the fileserver running at the same time.
Normally, this file is deleted every time the fileserver is stopped, but in rare circumstances, that does not happen. In such situations, the next time you try to use the component, the pre-existing lock file will not allow the operation, and the system notifies you with the error message.
Environment
The contents of this document were created while working in an IBM Security Guardium™ v11.3 system.
The process documented as the solution should remain equivalent in other versions of the product, with slight changes in the output, menu names and options.
Resolving The Problem
To resolve the problem, the existing lock file must be removed.
1. Log in to the command-line interface, with the cli user.
2. Execute the "diag" command.
diag
3. The diagnostic tool window is displayed. At the "Main Menu" screen, select option "4 Perform maintenance actions".
4. At the "Maintenance" screen, select "3 Clean disk space".
5. In the "Select a Directory:" window, it is possible to choose a directory to search for files to be deleted. Choose the "/var/tmp" option.
6. In "Search string, leave blank for no filter", it is possible to enter a search pattern so that the utility can find files whose names match it. Enter exactly the following string.
fileserver_started |
Tip 1. This process is also useful when you want to remove some old log files from the Guardium™ appliance in order to reclaim disk space.
The search is not recursive, it is done only in the selected directory, without going through subdirectories.
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7. After the utility finishes searching for the files that match the pattern, the files found will be displayed in a list.
8. In "Would you like to remove the files?", confirm the action to remove the found files.
9. Finally, a notification message will be presented. Selecting "OK" returns you to the "4 Perform maintenance actions" window.
10. Up to this point, you can close the tool to return to the Guardium™ command-line interface, and try to run the fileserver again.
Tip 2. There are slight changes in the way the fileserver command is executed depending on the product version.
If you are not familiar with it, you can get basic help through the help option.
Example.
[ip_address]. It is the IP address of the machine from where you are going to access the file server (it can be the same IP address of the machine from where you logged to the CLI in the first place).
[duration]. Time in seconds during which the file server remains active. After that time has elapsed, or when you hit the "Enter" in the CLI window, the file server will be stopped.
Read the IBM Security Guardium™ documentation to know more about the fileserver utility.
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Related Information
Document Location
Worldwide
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Document Information
Modified date:
19 October 2021
UID
ibm16173439