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Cliniq patch test failure during WinCollect installation on QRadar

Troubleshooting


Problem

WinCollect patch upgrade fails with "Unable to run Cliniq" error.
During the patch upgrade, the process fails with an error similar to this example:

[INFO](-i-testmode) Determining newest version of cliniq, based on patch config
[ERROR](-i-testmode) Unable to find cliniq at /opt/qradar/support/cliniq or /media/updates/cliniq/cliniq
[ERROR](-i-testmode) Unable to run cliniq.
[INFO](-i-testmode) Set ip-136 status to 'Patch Test Failed'
[ERROR](-i-testmode) Patching can not continue

Cause

This error occurs in a WinCollect environment that was originally installed before QRadar used the Cliniq command-line interface health check tool, and does not have auto-updates enabled. Cliniq is not installed in this environment. Newer updates run a check for Cliniq, but it is not required.

Resolving The Problem

  1. Option 1: Ignore Cliniq
    1. Instead of running the ./installer command, run ./installer --skip-cliniq to skip the Cliniq tests.
    2. Tip: There is no harm in running the Cliniq tests if Cliniq is available on your QRadar system.
  2. Option 2: Replace the missing Cliniq
    1. Locate the currently available version of Cliniq for your Qradar Deployment on the QR Console
      1. Run command:  locate cliniq
      2. Create a symbolic link from /opt/qradar/support to the currently available version of Cliniq.
        For example, on QRadar 7.5.0 UP7, the command would be:
cd /opt/qradar/support ln -s /opt/qradar/support/bin/cliniq/cliniq-0.4.3 cliniq 
Rerun the Wincollect sfs upgrade with either the ./installer --skip-cliniq option or after creating the symbolic link.

Document Location

Worldwide

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Document Information

Modified date:
30 April 2024

UID

ibm16172899