Troubleshooting
Problem
Consider the below scenario where the flag "Allow refund to exceed charge amount" on Return Order is enabled
1. Create a SO with 1 line/1 qty having price 1$ and line charges of 10. Order total is 11
2. Schedule, release, invoice and ship the order
3. Now create a draft return for this order with ProcessPaymentOnReturnOrder set to Y
3. Now create a draft return for this order with ProcessPaymentOnReturnOrder set to Y
4. Run the API - computeRefundPayments for this order. This shows PlannedRefundAmount="11.00"
5. Confirm the draft order, authorize and release the order. Record/report receipt and close receipt
6. . Create order invoice
7. Run requestCollection, Two charges are opened for 11$
6. . Create order invoice
7. Run requestCollection, Two charges are opened for 11$
Symptom
Refunds being opened are more than the amount charged
Cause
This is due to the order of the payment APIs being run.
Diagnosing The Problem
Refund charge processing needs to be completed entirely before creation of order invoice
Resolving The Problem
Run requestCollection after calling the API computeRefundPayments to complete processing of the refunds. The API createOrderInvoice needs to be run post running of requestCollection
Document Location
Worldwide
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Document Information
Modified date:
09 April 2020
UID
ibm16156009