IBM Support

"Not authorized ... Invalid login response received (empty)" when logon to Controller Web, solved by running 'SyncDBConf.bat'

Troubleshooting


Problem

User launches Controller Web website. User types in username/password. An error appears.

Symptom

image 2746
Not authorized
Close

Cause

There are several possible causes for this error.
  • TIP: See separate IBM Technote #1288582 for more examples.
This Technote specifically relates to the scenario where the cause is that the Controller application server's settings (for example database connections) have recently changed, so that they need to be updated.

Environment

In one real-life example, the problem occurred after patching from Controller 10.4.2 RTM to IF2.

Diagnosing The Problem

Inside the Controller Web log file, there are entries similar to:
2020-04-06 12:09:33 | <?>@<?> | ERROR | [com.ibm.cognos.fcm.wmc.ccrws.DefaultCcrClient] [CCR-WS] Cannot login user ADM@servername\databasename: Invalid login response received (empty).

Resolving The Problem

Update the Controller Web database connections, by running 'SyncDBConf.bat'.
Steps:
Assuming that Controller has been installed in the default location, run these two commands:
 
cd C:\Program Files\IBM\cognos\ccr_64\fcmweb
SyncDBConf.bat ..\Data wlp\usr\shared\config\datasources
 
TIP: For more details, see separate IBM Technote #289719.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"ARM Category":[{"code":"a8m0z000000GnFaAAK","label":"Controller WEB"}],"ARM Case Number":"TS003561798","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.4.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
06 April 2020

UID

ibm16155529