IBM Support

"Failed to register ExcelLink Addin ... Add method of AddIns class failed" error when launch Excel, when logged on as different user from the person who installed/upgraded Controller client

Troubleshooting


Problem

User launches Excel. An error appears.
Problem only affects some users (specifically, only some Windows user accounts who logon to the client device).

Symptom

 
image 2690
Failed to register ExcelLink Addin
Add method of AddIns class failed

Cause

There are several known causes for this error.
  • For more examples, see separate IBM Technote #1284004.
This Technote specifically relates to the scenario where the cause is that the end user has a missing registry entry in their Windows user profile
Example
In one real-life example:
  • The Controller client is being run on a Terminal Server (via Remote Desktop)
  • Controller client was installed by the local Windows user 'administrator'
    • Everything worked OK when logged onto Windows as the user 'administrator'
  • The problem affected all other Windows users (even if they had Windows-administrative rights). 
The cause was that the 'bad' users were missing this registry key:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Excel\Options]
"OPEN"="\"C:\\Program Files\\ibm\\IBM Cognos Controller Local Client\\adxloader.Controller.ExcelLink.dll\""
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Environment

This could occur in any environment, but it is more likely to be seen in a Citrix (or Terminal Services) environment, where it is typical/normal for both of the following to be true:
  • Controller client installed when logged on to Windows as an I.T. department's administrative user account
  • Excel launched when logged on to Windows as multiple different (standard) users

Resolving The Problem

Add the relevant missing registry key to the Windows user profiles of the 'bad' users.
Example:
In one real-life example, the solution was to add this key:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Excel\Options]
"OPEN"="\"C:\\Program Files\\ibm\\IBM Cognos Controller Local Client\\adxloader.Controller.ExcelLink.dll\""
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 
TIP: The above text can be found inside the contents of the attached file "TN6123627_registry_REG_file_fix.txt" : TN6123627_registry_REG_file_fix.txt

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
27 March 2020

UID

ibm16123627