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Agent unreachable - Cannot display resource information - In the Databases tab of the Planning Analytics Workspace administration page

Troubleshooting


Problem

 In the Databases tab of the Planning Analytics Workspace administration page, an "Agent unreachable" error is displayed at the top, and a "Cannot display resource information" error is displayed for each monitored TM1 Server database.

Symptom

In the messages.log file, that can be found in "C:\Program Files\ibm\cognos\tm1_64\paa_agent\wlp\usr\servers\kate-agent\logs\" directory, the following errors appear:
[24/03/20 17:17:18:092 GMT] 0000003b SystemErr                                                    R ERROR:status.py:Error getting the OS Details: index out of range: 0
Traceback (most recent call last):
  File "kateagent/scripts\status.py", line 862, in <module>
    drive, path = os.path.splitdrive(data_directories[0])
IndexError: index out of range: 0
[24/03/20 17:17:18:092 GMT] 0000003b te.agent.service.PaKateServerUnresponsiveNotificationService E Error occurred while getting latest servers info from json file
Traceback (most recent call last):
  File "kateagent/scripts\status.py", line 1144, in <module>
    status['used_system_disk'] = system_status['used_system_disk']
NameError: name 'system_status' is not defined

Cause

In the "status.py" Python file that resides in "C:\Program Files\ibm\cognos\tm1_64\paa_agent\wlp\usr\servers\kate-agent\kateagent\scripts", there is a line that does not work on Windows Server 2012:
    drive, path = os.path.splitdrive(data_directories[0])
 
This line is at the beginning of a code section that should determine the OS system that we are running on (either 'windows' or 'linux').
The whole subsequent code in this section is failing because of this line.

Environment

PA Workspace is installed on either Windows Server 2016 or Linux, and "IBM Planning Analytics Administration Agent" service is running on a separate Windows Server 2012.

Resolving The Problem

The faulty line has been removed from PAAA version 2.0.48, which is now provided by PA Workspace (not Planning Analytics Local anymore)
Steps to solve the problem:
- Download PA Workspace version 2.0.48 or later
- Upgrade the current installation with this version
- Connect to PA Workspace, go to Administration, select the Databases tab
- On the top-right, click the "Download" link, and download the new version.
- Copy the downloaded file (like "paa-agent-pkg-2.0.*.zip") to the Windows Server 2012 machine where PAAA service is running.
- Extract the Zip file to any temporary folder
- Open a cmd.exe command window and run this command:
UpdatePAAAgent.bat "C:\Program Files\ibm\cognos\tm1_64"
This will stop the service, upgrade the Agent, and restart the service at the end.
Finally, verify the Agent has been correctly upgraded by checking the content of this file:
C:\Program Files\ibm\cognos\tm1_64\paa_agent\wlp\usr\servers\kate-agent\version.txt

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"Component":"Planning Analytics Administration Agent;PAAA","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2.0.47","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
26 March 2020

UID

ibm16120753