IBM Support

"Failed to launch! ... java.lang.NullPointerException" launching Java-related functionality, caused by defect in 10.4.2 RTM (10.4.2000.252)

Troubleshooting


Problem

User tries to launch any JAVA-related menu item (for example "Command Center"). User receives error. All users affected.

Symptom

The error will vary depending on what menu item is launched.
Example ("Maintain - Jobs - Define"):
image 2654
com.ibm.cognos.ccr.integration.IntegrationFacadeException: org.eclipse.core.runtime.adaptor.EclipseStarter failed!
    at com.ibm.cognos.ccr.integration.IntegrationServiceAdapter$MyEclipseStarter.run(IntegrationServiceAdapter.java:169)
    at java.lang.Thread.run(Thread.java:818)
Caused by: com.ibm.cognos.ccr.common.FatalException: Failed to launch!
    at com.ibm.cognos.ccr.integration.application.internal.IntegrationApplication.start(Unknown Source)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at com.ibm.cognos.ccr.integration.IntegrationServiceAdapter$MyEclipseStarter.run(IntegrationServiceAdapter.java:167)
    ... 1 more
Caused by: java.lang.NullPointerException
    at java.util.Hashtable.put(Hashtable.java:506)
    at java.util.Properties.setProperty(Properties.java:179)
    at com.ibm.cognos.ccr.common.ServerConfiguration.getBeanFactoryProcessors(Unknown Source)
    at com.ibm.cognos.ccr.common.Configuration.createApplicationContext(Unknown Source)
    at com.ibm.cognos.ccr.common.ModelFactoryFinderImpl.getApplicationContext(Unknown Source)
    at com.ibm.cognos.ccr.common.ModelFactoryFinderImpl.haveBean(Unknown Source)
    at com.ibm.cognos.ccr.common.DefaultModelContext.haveBean(Unknown Source)
    at com.ibm.cognos.ccr.common.DefaultModelContext.haveSessionInfo(Unknown Source)
    at com.ibm.cognos.ccr.core.ui.server.SessionInfoUtil.getSessionInfo(Unknown Source)
    at com.ibm.cognos.ccr.integration.application.internal.IntegrationApplication.processSetup(Unknown Source)
    ... 7 more

Cause

There are several possible causes for similar error messages.
  • TIP: For more examples, see separate IBM Technote #478825 .

This Technote specifically relate to the scenario where the cause is a defect in 10.4.2 RTM (10.4.2000.252).

Environment

Controller 10.4.2 RTM (10.4.2000.252)

Diagnosing The Problem

Inside the 'Log' folder (default: C:\Program Files\ibm\cognos\ccr_64\log) the ccr.log file is empty:
image 2652

Resolving The Problem

Upgrade to Controller 10.4.2 IF1 (10.4.2000.259) or later.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.4.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
24 March 2020

UID

ibm16116608