IBM Support

Planning Analytics IBM Cognos Configuration Crashes on Startup

Troubleshooting


Problem

When launching IBM Cognos Configuration from the Start Menu, it crashes after a couple of seconds.

Symptom

The Event Viewer displays the following message in the Application Log --> Click on one of the 'Information rows ' --> 'IBM Java cannot be found'

Cause

There may be external factors in the environment that are restricting the IBM Java process from running.  Cognos Configuration requires IBM Java to run. You will have to identify the external application blocking IBM Java and uninstall it from your environment.

Resolving The Problem

At the time of the creation of this technote, we identified Centrify Agent for Windows as one of the applications blocking IBM Java.  This is just one example however there could be other software causing the same issue.
Download Process Explorer and look for any unknown processes running in the background.  Investigate more on such processes and identify the ones that could be blocking IBM Java (any process that does the job of virus scanning, auditing, etc.).
Download Process Monitor and capture the Cognos Configuration crash.  Find cogconfigw.exe Process Name to find out what could be blocking the cogconfigw.exe process.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
21 September 2021

UID

ibm15736843