Troubleshooting
Problem
After upgrading from Control Center 6.1.0.1 to 6.1.1.0 iFix03 we can no longer attach to Congos and run reports from Control Center.
Symptom
Cognos Reports are unavailable
Cause
Cognos database not properly registering new version of Cognos
Environment
Oracle database
Diagnosing The Problem
Look at logs
<CC install>/Cognos/logscogconfig_response.csv shows
ERROR, "[Start Service]", "CFG-ERR-0106 IBM Cognos Configuration did not receive a response from the IBM Cognos service in the time allotted.
<CC Install>/Cognos/logs/cogserver.log shows
BootstrapConfigurePublish DPR-DPR-1035 Dispatcher detected an error. Error configuring nulljava.lang.NullPointerException
Resolving The Problem
1) Run SQL: select * from CMOBJNAMES where CMID in (select CMID from CMOBJECTS where CLASSID = '14')
2) Note the CMID from the result of the SQL in step 1.
3) Run SQL: select * from CMOBJPROPS58 where EDITION is NULL or EDITION = ''
4) Look in {ICCInstallDir}/Cognos/cmplst.txt and get the value for "DISP_version=" (should be 11.0.5.3).
5) If the CMID noted in step 2 is also listed as a CMID in the second query from step 3, then edit and run this query:
update CMOBJPROPS58 set EDITION = 'versionValueFromStep4' where CMID = 'cmidFromStep2&4'
For example,
update CMOBJPROPS58 set EDITION = '11.0.5.3' where CMID = '202'
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Document Information
Modified date:
17 December 2019
UID
swg22017130