Troubleshooting
Problem
Attempts to login to IBM Sterling Business Center leads to error Please contact system administrator post upgrade.
Symptom
Clicking on Menu does not work after logging in. The below error is seen.
Ext.MessageBox.show({ title: 'Error', msg: 'An error has occurred. Please contact system administrator.', width:300, buttons: Ext.Msg.OK, icon: Ext.MessageBox.ERROR });
Cause
- FP Factory setup not applied.
- Usage of an old web,xml
Diagnosing The Problem
Check and confirm that FP factory setup is applied successfully. You may check <INSTAL_DIR>/database\fp-factorysetup for existence of .restart files.
Compare the web,xml present in the EAR with <INSTAL_DIR>\repository\eardata\sbc\extnweb.xml.sample and confirm the changes available is present.
Resolving The Problem
Steps to resolve:
- Run FP factory setup.
- Make sure the value of LOAD_FACTORY_SETUP is set to true in sandbox,cfg.
- Run the below command to load FP factory setup data
> sci_ant.cmd -DFROM_FP=<From_FPNumber> -DTO_FP= <To_FPNumber> -DFORCE_DELETE_RESTART_FILES=true -f FSHelper.xml smcfs-datamigration
For example:
To execute FP factory changes from FP1 to FP 18, run the following command
> sci_ant.cmd -DFROM_FP=1 -DTO_FP=18 -DFORCE_DELETE_RESTART_FILES=true -f FSHelper.xml smcfs-datamigration
- After running the above command confirm that .restart files are generated in <INSTALL_DIR>\database\fp-factorysetup folder.
- Merge web,xml changes present in <INSTAL_DIR>\repository\eardata\sbc\extnweb.xml.sample,
- Recreate the EAR and redeploy
Product Synonym
Sterling OMS
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Document Information
Modified date:
16 June 2018
UID
swg22017086