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Tax is getting calculated as zero in over receiving scenario

Question & Answer


Question

Why Tax gets calculated as 0 when item quantity is over received in Sterling Order Management?

Cause

Incorrect input xml is used.

Answer

Sample Scenario:

  1. Create a PO with 2 ordered item quantity.


  2. Schedule and release the order. Create and confirm the order shipment.


  3. Call receiveOrder API to receive 1st item.


  4. Call receiveOrder API to receive 2nd item. YFS_ORDER_LINE table shows the correct RECEIVED_QUANTITY and TAX value.


  5. Call receiveOrder API to over receive 3rd item. YFS_ORDER_LINE table shows the RECEIVED_QUANTITY as 3 but TAX value as 0.

Order was created with line tax details but it did not have the charge name on which that tax should be applied on.
For example:
<LineTaxes>
<LineTax Tax="1" TaxName="Tax" TaxPercentage="1"/>
</LineTaxes>

When a pricing quantity is changed, product needs to recalculate the line taxes. If order is created with the taxes, having correct charges and tax percentage, then product recomputes to the correct tax. But if that is NOT the case then product will reset Tax to 0.

In this case, Order did not have the charge name on which the tax should have been applied on.
Corrected part of input XML :
<LineTax ChargeCategory="Price" ChargeName="Price Ticket" Tax="1"  TaxName="Tax" TaxPercentage="1" />

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.5;9.4;9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22016704