IBM Support

Some users get an error when trying to access Cognos Analytics:provided credentials are restricted from accessing IBM Cognos ”

Troubleshooting


Problem

Some users receive an error when trying to access Cognos Analytics

Symptom

Unable to authenticate. The provided credentials are restricted from accessing IBM Cognos

Cause

The “Restrict access to members of the built-in namespace” parameter is set to true in IBM Cognos Configuration.

Diagnosing The Problem

Adding the user to the System Administrators group resolves the issue

Resolving The Problem

The ” Restrict access to members of the built-in namespace” parameter allows administrators to restrict user access to the application. When this parameter is set to true, users can only access the application if they belong to at least one group or role within the built-in namespace (does not include the group "All Authenticated Users").

Steps:

1. Open IBM Cognos Configuration.

2. In the Explorer Panel, click on the Security -> Authentication and set the “Restrict access to members of the built-in namespace” to “False”.

3. Save and restart services.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22016283