IBM Support

Communication with Guardium CM may timeout after p6024 applied

Troubleshooting


Problem

IBM Security Guardium units patched with v10p6024 (the Spector/Meltdown security patch) may experience timeouts communicating with the Central Manager (CM). A fix for this issue is available in bundle patch v10p408.

Symptom

Managed units on the CM turn red in the Central Management view. You cannot push patches or policy while the unit shows as red.

Restarting the GUI may get the units to show green briefly, but they soon turn red again. Some units may still show as green. Which units turn red may not be consistent.

Cause

If certain tables are very large, performance in some queries is slow enough to cause a timeout after p6024 is applied. This causes the unit to turn red on the CM.

Environment

This issue can affect any v10 Guardium system, including v10.5.

Not all systems are affected. Certain tables need to be very large to trigger it.

Resolving The Problem

Apply patch v10p408 which available now on Fix Central.

Once this issue surfaces patches cannot be pushed from the CM, so p408 must be applied locally to each affected unit. To avoid connection issues, apply p408 before applying p6024.

If possible, apply p408 before upgrading to v10.5. For systems already at v10.5, p408 cannot be applied. The next bundle patch for v10.5 will contain this fix. Check the Release Notes for bug GRD-17031 or APAR GA16342.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Central Manager and Aggregator","Platform":[{"code":"PF016","label":"Linux"}],"Version":"10.1.2;10.1.3;10.1.4;10.5","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22016103