IBM Support

Why is there an HTTP 404 Result when hitting http://<machine>:9300/bi/v1/users/~/items/uihints?

Troubleshooting


Problem

When watching the interaction, there is an HTTP result that indicates a 404 (file not found) when hitting http://:9300/bi/v1/users/~/items/uihints

Cause

Cognos Analytics uses HTTP Results to identify things that may or may not exist in the UI for the purposes of determine whether or not an object exists internally. If it does not exist internally, the result code of 404 is provided back.

This keeping within the HTTP Result methodology and in this case, it is not an error. No actionable items are required to be performed due to it from a user/admin perspective.

Resolving The Problem

This is not a problem with the software.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Portal v11x","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0.10;11.0.9;11.0.8;11.0.7;11.0.6;11.0.5;11.0.4;11.0.3;11.0.2;11.0.1;11.0","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22016065