IBM Support

OKTA namespace sets wrong Content Language in Cognos

Troubleshooting


Problem

CountryCode (User field from Okta) is being used for Content Language setting on Cognos. Environment has been setup as per this document: https://www.ibm.com/communities/analytics/cognos-analytics-blog/adminis…

Symptom

The issue is for example Cognos is reading AR as language Arabic, instead of AR for country Argentina.
Another problem is that the users cannot manually change the Content Language on their profile in Cognos. Everytime they login back, the language is set back to Arabic. Same thing with users in Panama (country code PA) have their content language set to Punjabi. It should be Spanish.

Cause

When a new application is created in OKTA, the locale mapping is automatically set to:

user.countryCode == null ? "en-US" : (String.stringContains(user.countryCode, "_") ? String.substringBefore(user.countryCode, "_") + "-" + String.substringAfter(user.countryCode, "_") : user.countryCode)

Resolving The Problem

Set the locale mapping in OKTA's profile editor to the string bellow:
user.locale == null ? "en_US" : user.locale

Another option is to set the locale mapping to null. This way the user is able to manually change the content language in Cognos to any language.

Steps:

  1. In Okta, go to the Profile Editor and then Mappings.
  2. Find the locale mapping and switch to
    user.locale == null ? "en_US" : user.locale
  3. Apply to all.
  4. Sign out from Cognos, sign out from Okta.
  5. Login to Cognos, the content language should be set correctly now.

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Document Information

Modified date:
15 June 2018

UID

swg22015950