IBM Support

Cognos Drill through on PDF report fails with "The webpage cannot be found - HTTP 404"

Troubleshooting


Problem

I am running the drill through source report as PDF. When I click on the drill link to go to the target report, I get this message "The webpage cannot be found - HTTP 404". We are using SSL in the Cognos Analytics environment.

Cause

The Cognos gateway URI in the configuration was using an incorrect port since they are using SSL

Resolving The Problem

Gateway URI was originally https://<ServerName>:9300/ibmcognos/bi/v1/disp
and changing it to https://<ServerName>:443/ibmcognos/bi/v1/disp
resolved the PDF drill through issue.

Open IBM Cognos Configuration.
Update the Gateway URI value with the fully qualified domain name and if you are using SSL also use port 443 in the Gateway URI.
Save the configuration and restart Cognos services.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0.10;11.0.9;11.0.8","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg22015669