Troubleshooting
Problem
Attempts to create new sourcing rule using Application Manager leads to the error PLT0602 in IBM Sterling Order Management.
Symptom
Below error thrown while creating new sourcing rule in configurator
<?xml version="1.0" encoding="UTF-8"?>
<Errors>
<Error ErrorCode="PLT0602"
ErrorDescription="Error description not available"
ErrorRelatedMoreInfo="">
<Attribute Name="ErrorCode" Value="PLT0602"/>
<Attribute Name="ErrorDescription" Value="Error description not
available"/>
<Attribute Name="Method" Value=""/>
<Attribute Name="AttributeName" Value="ItemClassification4"/>
<Attribute Name="EntityName" Value="Sourcing_Rule_Header"/>
<Stack>com.yantra.yfc.util.YFCException
at
com.yantra.yfc.dblayer.YFCEntity.validateFeatureVersion(YFCEntity.java:7
34)
Cause
SI_VERSION table is not updated with latest version
Resolving The Problem
Steps to resolve:
- Navigate to the INSTALL_DIR>/bin directory. Here, INSTALL_DIR refers to the installation directory of the new version.
- Invoke the following script {runtime}/bin/ fullRollOutDataMigration.cmd/sh..
NOTE:
The script has to be executed from the new RUNTIME
For example, if you upgraded from version 9.4 to 9.5, the script has to be executed from 9.5_INSTALL_DIR/bin folder. The script updates the SI_VERSION table, and makes it the base version in the entire deployment to 9.5.
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Document Information
Modified date:
16 June 2018
UID
swg22015534