IBM Support

Getting "Forbidden" error when logging into TM1Web using CAM security

Troubleshooting


Problem

After entering log in credentials, getting a "Forbidden" error.
image 2532

Symptom

The full URL when getting the Forbidden error looks something like this:
http://enamors1.fyre.ibm.com:9300/bi/v1/tm1/web/tm1web.html?cam_passport=MTsxMDE6YWQ2YTMxYzUtNWI4Ny03ODVlLWJmM2MtMzYwODVjMTY1MzBkOjE1MTU3NjkyNjA7MDszOzA7&server=24retail&ps=http%3a%2f%2fglia1.fyre.ibm.com%3a9510&pg=applications.jsp&host=levan1.fyre.ibm.com
when comparing this URL to the same call for a working URL in a Fiddler trace, you will notice that the working URL has the extension
...:9300/bi/tm1/web/tm1web.html...
and the broken URL looks like
...:9300/bi/v1/tm1/web/tm1web.html...
there is no /v1/ directory in the /bi/ folder, so this is expected to throw an error.

Cause

One possible cause is that the ClientCAMURI in the tm1s.cfg file has a / at the end of the URL. For example:
ClientCAMURI=http://enamors1.fyre.ibm.com:9300/bi/v1/disp/
instead of
ClientCAMURI=http://enamors1.fyre.ibm.com:9300/bi/v1/disp

Resolving The Problem

Remove the "/" at the end of the URL of the ClientCAMURI in the tm1s.cfg file, save the file.  Wait ~60 seconds for the change to take effect and retest.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"Component":"TM1Web","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
21 September 2021

UID

ibm15695587