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Unable to see customization option on Call center for commerce 9.5

Troubleshooting


Problem

Attempts to deploy isccsdev war does not display the customization option in IBM Call Center for Commerce.

Symptom

Steps to simulate:

  1. Created ear using the parameters as below:

    buildear.cmd -Dappserver=websphere -Dwarfiles=smcfs,sma,sbc,wscdev,isccsdev -Dearfile=smcfs.ear -Dnoejb=true -Dnowebservice=true -Duidevmode=true -Ddevmode=true  -Dnodocear=true -Dnodocwar=true

  2. Set WAS - JVM parameters:
    -Dvendor=shell -DvendorFile=C:\Sterling\SSFS95\properties\servers.properties -DuiExtensibilityMode=true -Dwufdevmode=true -Ddevmode=true

    The options customize and customize from outline do not appear when logged in as a admin user.

Cause

The dev mode is set to false in Websphere application server.

Environment

Websphere Application Server. -Dwarfiles=isccsdev parameter is used while creating EAR and -DuiExtensibilityMode=true, -Dwufdevmode=ture, -Ddevmode=true are added
in WAS system(JVM) argument.

Diagnosing The Problem

The WAS server logs show IS_DEV_WAR being set to false.

Resolving The Problem

Steps to resolve:

  1. Go to location :- <INSTALL_DIR>\repository\eardata\isccsdev\extn.


  2. Make changes to this web.xml file to ensure the following is set.
    -----------------
        <context-param>
           <param-name>isDevWar</param-name>
           <param-value>true</param-value>
       </context-param>

    -----------------

  3. Rebuild the isccsdev war file.

  4. Deploy the war file.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Documentation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
11 February 2020

UID

swg22015406