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IBM Security Guardium : Unusal N/A traffic logged in Guardium

Question & Answer


Question

Why am I seeing unusual N/A traffic in session list report?
image-20200306201628-1

Cause

The Client/server data is logged as N/A (unavailable) for the policy violations which are generated by Threshold Alerts.

Answer

Open the Alert Builder in GUI -
Protect > Database Intrusion Detection > Alert Builder.
If 'log policy violation' is checked in threshold alert definition then policy violations are generated by a threshold alert and an entry is logged in internal table with server type as 'GUARDIUM', service name as 'THRESHOLD ALERT'  and client ip/server ip etc. as 'NA'.
When policy violations are generated by a threshold alert, there is no actual session that triggered the violation but a report (with some criteria on each record or all records).
For this reason policy violations created by threshold alerts do not have a valid session id (is populated using a dummy session) and this causes the Client/server data to be unavailable (NA) for these policy violations.

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Product Synonym

IBM Guardium

Document Information

Modified date:
09 March 2020

UID

ibm15693451