IBM Support

Why is the ErrorCode="YFC0001" not being thrown when a duplicate order is created?

Troubleshooting


Problem

When DB2 is used and a duplicate order is created, the error code YFC0001 is not thrown. Instead the ErrorCode thrown is - The expectation is to have the DB2 error match to the platform error codes in IBM Sterling Order Management

Cause

This is due to the DB2 driver version being used.

Diagnosing The Problem

The Error code "-4228" indicates that - An error occurred that does not fit in another category.
Since this exception is not known to the Sterling platform, it is unable to map it with any YFC exception.

Resolving The Problem

Use the supported driver with the DB2 version being used to resolve this issue.
The below link provides details of the supported DB2 driver versions-
http://www-01.ibm.com/support/docview.wss?uid=swg21363866

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF003","label":"Android"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"9.3;9.4;9.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22014858