Troubleshooting
Problem
Attempts to create order in IBM Sterling Order Management leads to the error Invalid Identifier 'ROLLOUT_VERSION' after applying fixpack 14.
Cause
The database changes are not applied during fixpack installation due to incorrect property settings in sandbox.cfg.
Diagnosing The Problem
During product upgrade, the following properties are set to false:
- REINIT_DB=false
- LOAD_FACTORY_SETUP=false
- NO_DBVERIFY=true in sandbox.cfg,
Due to this setting, the DB changes were not applied during FP installation.
Resolving The Problem
To resolve, revert the values to the following:
- REINIT_DB=true
- LOAD_FACTORY_SETUP=true
- NO_DBVERIFY=false
This will apply the changes to the database.
This step is already documented in post migration steps in knowledge center
[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]
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Document Information
Modified date:
16 June 2018
UID
swg22014398