IBM Support

IBM Security Guardium : GIM Installation Failure with MD5SUM Error

Troubleshooting


Problem

GIM client is attempted for installation on AIX server. Output after executing the .gim.sh file on the server. Sample Message : Verifying archive integrity...Error in MD5 checksums: A1C93DB63757B1BFD78B5829A79F82BF is different from c73ada0578d7e91809aab7fc301c64cb

Symptom

Sample Installation Attempt :
./guard-bundle-GIM-10.1.3_r101342_v10_1_3_1-aix-7.1-aix-powerpc.gim.sh -- --dir /opt/guardium --sqlguardip <GDM_APPLIANCE_IP> --tapip <DATABASE_SERVER_IP>
Verifying archive integrity...Error in MD5 checksums: A1C93DB63757B1BFD78B5829A79F82BF is different from c73ada0578d7e91809aab7fc301c64cb

Cause

The cause of this message is said to happen when the makeself embedded value of checksum is different than the value generated by the actual checksum binary's generated value while installation.

Environment

AIX & V10.1.3 and V10.1.4 GIM client but this might as well could be applicable for other Unix like environments.

Diagnosing The Problem

1- Make sure the files are transferred to the server using binary transfer method
2- Make sure the installation is tried on more than 1 servers at least
3- MD5SUM can be checked using the below sample command in AIX:

csum -h MD5 guard-bundle-GIM-10.1.3_r101342_v10_1_3_1-aix-7.1-aix-powerpc.gim.sh

Resolving The Problem

Execute the command "export SETUP_NOCHECK=1" and run install from same console and see if it works.
If it still does not work, please engage the IBM Security Guardium Support.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium S-TAP","Platform":[{"code":"PF002","label":"AIX"}],"Version":"10.0;10.0.1;10.1;10.1.2;10.1.3;10.1.4","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Historical Number

TS000124330

Document Information

Modified date:
16 June 2018

UID

swg22014380