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Guardium Installation Manager (GIM) client installation on Windows fails in IBM Security Guardium

Troubleshooting


Problem

GIM client installation fails on Windows in IBM Infosphere Guardium and following log found in c:\guardiumstaplog.txt ===================== 8-22-2017 08:48:23: Gim Client: OnBegin 8-22-2017 08:48:23: Gim Client: running in silent mode. CMD= --host=10.10.10.10 --path=C:\\Program Files (x86)\\guardium\\GIM --localip=172.24.1.83 8-22-2017 08:48:23: Gim Client: Trimming leading and tailing spaces host=10.10.10.10 8-22-2017 08:48:23: Gim Client: Trimming leading and tailing spaces path=C:\\Program Files (x86)\\guardium\\GIM 8-22-2017 08:48:23: Gim Client: Trimming leading and tailing spaces localip=172.0.0.0 8-22-2017 08:48:23: Gim Client: Using bundled perl 8-22-2017 08:48:23: Gim Client: Host: 10.10.10.10 Path: C:\\Program Files (x86)\\guardium\\GIM Perl: C:\\Program Files (x86)\\guardium\\GIM\spp2\perl\bin\perl.exe Local IP: 172.0.0.0 8-22-2017 08:48:23: Gim Client: OnBegin end 8-22-2017 08:48:23: Gim Client: OnFirstUIBefore begin 8-22-2017 08:48:23: Gim Client 8-22-2017 08:48:24: Gim Client: OnMoving emd 8-22-2017 08:50:39: Gim Client: OnAbort begin 8-22-2017 08:50:41: Gim Client: OnAbort deleted 8-22-2017 08:50:41: Gim Client: OnAbort after remove all ========================

Symptom

You see the following type of messages in c:\guardiumstaplog.txt

8-22-2017 08:31:13: Gim Client: Host: **.**.**.** Path: c:\\program
files(x86)\\guardium\\GIM Perl: c:\\program
files(x86)\\guardium\\GIM\spp2\perl\bin\perl.exe Local IP: 1.1.1.1
8-22-2017 08:31:13: Gim Client: OnBegin end
8-22-2017 08:31:13: Gim Client: OnFirstUIBefore begin
8-22-2017 08:31:13: Gim Client: Adding version file
8-22-2017 08:31:14: Gim Client: OnMoving begin
8-22-2017 08:31:14: Gim Client: OnMoving emd
8-22-2017 08:35:22: Gim Client: OnAbort begin
8-22-2017 08:50:41: Gim Client: OnAbort deleted
8-22-2017 08:50:41: Gim Client: OnAbort after remove all

Cause

The issue occurs because Perl (version 5.8.x or 5.10.x) package is not installed on the database server thus the GIM client installer is not able to locate the Perl bundle.

Environment

InfoSphere Guardium Appliances 9.5.0

Diagnosing The Problem

Check the guardiumstaplog.txt which is located under the main windows directory (usually C:/) on the Windows database server. You are in presence of this problem if you see messages similar to the ones below:

8-22-2017 08:31:13: Gim Client: Host: **.**.**.** Path: c:\\program
files(x86)\\guardium\\GIM Perl: c:\\program
files(x86)\\guardium\\GIM\spp2\perl\bin\perl.exe Local IP: 1.1.1.1
8-22-2017 08:31:13: Gim Client: OnBegin end
8-22-2017 08:31:13: Gim Client: OnFirstUIBefore begin
8-22-2017 08:31:13: Gim Client: Adding version file
8-22-2017 08:31:14: Gim Client: OnMoving begin
8-22-2017 08:31:14: Gim Client: OnMoving emd
8-22-2017 08:35:22: Gim Client: OnAbort begin
8-22-2017 08:50:41: Gim Client: OnAbort deleted
8-22-2017 08:50:41: Gim Client: OnAbort after remove all

Resolving The Problem

  • For non silent installation: Install the perl package before installation of GIM client
  • For silent installation: Provide the path to the perl installer (included with the GIM product) in the installation command, similar to below command:

setup.exe /s /z" --host=1.1.1.1 --path=C:\\Program Files (x86)\\guardium\\GIM --perl=C:\\Program Files (x86)\\guardium\\GIM\spp2\perl\bin --localip=2.2.2.2"

Perl path is within the GIM client installer
--perl=C:\\Program Files (x86)\\guardium\\GIM\spp2\perl\bin

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.5","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22007683