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IBM Guardium Security: GIM fails install ./autoinstall.sh: Permission denied

Troubleshooting


Problem

Guardium Installation Manager (GIM) installation fails with the following message: ./guard-bundle-GIM--.gim.sh -- --dir --sqlguardip= --tapip= Verifying archive integrity... All good. Uncompressing Guard BUNDLE-GIM Installer.... ./guard-bundle-GIM--.gim.sh: line 123: ./autoinstall.sh: Permission denied

Cause

Execution is restricted on /tmp or /var/tmp

Diagnosing The Problem

You are using root to install GIM and you have checked that root has full permission on the designated installation directory and the PERL library. Though you are logged in as root and the file system shows full permission, there are other ways to inhibit execution.

Run the mount command to check if noexec is set at the mount point on the /tmp or /var/tmp directories.

Resolving The Problem

When Guardium is running it uses /tmp where it uncompresses files, executes, and removes extracted files. There could be operating system rules that prohibit execution from within these directories for security reasons. There is no parameter or change (e.g. changing the installation directory) that will change this behavior. Use the steps below to redirect the use of /tmp:

mkdir <new directory>
chmod 777 <new directory>
export TMPDIR=<new directory>

Now re-run the installation script.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF016","label":"Linux"}],"Version":"10.0;10.0.1;10.1;10.1.2;10.1.3;9.0;9.1;9.5","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22007297