IBM Support

Invoiced line is getting re-priced when another non-invoiced line from same order is cancelled

Troubleshooting


Problem

Attempts to cancel a non-invoiced line in an order reprices the invoiced line in IBM Sterling Order Management.

Symptom

Steps to reproduce:

  1. Create a Pricing rule which applies $10 discount by distributing it on orderlines.


  2. Create a sales order having two orderlines.


  3. Ship the first order line and invoice it.


  4. Cancel the second orderline.
The first orderline's price is changed for adjusting the $10 discount on the order.

As the first orderline is shipped and invoiced, it's price should not have changed.

Cause

This is Working As Designed.

Diagnosing The Problem

Invoiced line is getting re-priced when another non-invoiced line from same order is cancelled, if both are associated via a promotion.
Product allows to change the price of invoiced line because the configuration Apply Price Change To Invoiced Quantity is checked under financial rule.
Since the pricing RuleType is ORDER_TOTAL, the $10 is first distributed to 2 orderlines. Once the second line is cancelled, order is repriced and the $10 discount is applied on the remaining first orderline.

Resolving The Problem

To cancel the second orderline and not change the price of invoiced line, you need to be handle this with the help of user exit - YPMOverrideGetOrderPriceUE.

For Example
You can implement this user exit to write their custom logic to set the price of invoiced line to original price.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.4","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22007224