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processReturnOrder API is not returning PlannedRefundAmount attribute under PaymentMethod element

Troubleshooting


Problem

Attempts to run processReturnOrder API does not return PlannedRefundAmount attribute under PaymentMethod element if the refund is to a cash payment in IBM Sterling Order Management System

Cause

In Cash payment method configuration, the refund configuration is set as refund to new payment method.

Diagnosing The Problem

Product does not calculate planned refund amount for payment methods with refund configuration Refund to new payment method.
When the refund configuration is Create Refund Payment and Wait for payment info along with Refund to new payment method then as there are no charges to be created at that point in time but only mark the payment method as await pay info, it was designed to populate the planned refund amount instead.
For option Create Refund Payment and Charge Request along with Refund to new payment method, system does not wait for payment method to be valid but create both payment method and refund CHARGE at the same time and hence the product does not populate planned refund amount.

Resolving The Problem

To calculate planned refund amount for all scenarios then you have to enable the below property :
yfs.calcPlanRefForAllSuppressRefSettleWaitTillReturnInv and set to Y in the customer_overrides.properties file.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22007222