IBM Support

CLOB DATA TYPE, SPECIAL CHARACTERS ARE DISPLAYED AS INVERTED QUESTION MARK IN FM and Report

Troubleshooting


Problem

Oracle CLOB data type, some special charters are displayed as inverted question mark within test data values from FM so report shows a wrong information to customer.

Symptom

EXPECTED RESULTS: show special characters "田氏" "솔루션"

ACTUAL RESULTS: the inverted question mark "¿¿" "¿¿"

Cause

NLS_LANG = .UTF8 system environment needs to be set for CQM Oralce import/test.
For Oracle, set the NLS_LANG (National Language Support) environment variable on each computer where Framework Manager or Metric Designer and the IBM

Environment

Oracle 11g, 12c

Diagnosing The Problem

Test special characters in FM

Resolving The Problem

set NLS_LANG=.UTF8
System Environment has to set up Oracle NLS_LANG (National Language Support).

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Report Authoring v11x","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0.6;11.0.5;11.0.4;11.0.3;11.0.2;11.0.1;11.0","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22007078