IBM Support

IBM Guardium Security - Uninstalling Guardium S-TAP 10.1.3 on Windows does not remove the S-TAP folder.

Troubleshooting


Problem

You uninstalled Guardium S-TAP 10.1.3 on Windows. You did not receive any error or notification of failure. Uninstall was successful, however, the S-TAP directory was not removed. It remains with some files in it.

Symptom

The S-TAP directory was not removed after uninstalling the S-TAP product and the installation log file IBM Windows STAP.ctl in the main Windows drive (ie. C:\IBM Windows STAP.ctl) contains one or more message like this:

Purge: Defer delete <path to a filename in the S-TAP directory>

Cause

Uninstall was unable to remove some libraries and/or executable files. Deletion of these files was deferred until next reboot.

Environment

Guardium S-TAP on Windows

Diagnosing The Problem

Review install log IBM Windows STAP.ctl log file in the main Windows drive (ie. C:\IBM Windows STAP.ctl).


You are in presence of this problem if you see messages like:

 Purge: Defer delete <Path to filename in the S-TAP directory>

followed by a successful message at the very end like:

 Finish: The uninstallation completed successfully

Sample last lines of a IBM Windows STAP.ctl log with this problem:


`I 07/24/2017 14:36:40.119    Purge: Defer delete C:\Windows\$IBM Windows S-TAP$\protobuf-net.dll
`I 07/24/2017 14:36:40.119    Purge:
Defer delete C:\Windows\$IBM Windows S-TAP$\IBM.Guardium.BaseForms.dll
`I 07/24/2017 14:36:40.119    Purge:
Defer delete C:\Windows\$IBM Windows S-TAP$\IBM.Guardium.Diagnostics.dll
`I 07/24/2017 14:36:40.119    Purge:
Defer delete C:\Windows\$IBM Windows S-TAP$\IBM.Guardium.Installer.dll
`I 07/24/2017 14:36:40.119    Purge:
Defer delete C:\Windows\$IBM Windows S-TAP$\IBM.Guardium.Interop.dll
`I 07/24/2017 14:36:40.119    Purge:
Defer delete C:\Windows\$IBM Windows S-TAP$\IBM.Guardium.IO.dll
`I 07/24/2017 14:36:40.119    Purge:
Defer delete C:\Windows\$IBM Windows S-TAP$\Setup.exe
`I 07/24/2017 14:36:40.119    Purge:
Defer delete C:\Windows\$IBM Windows S-TAP$\StapInstaller.exe
`I 07/24/2017 14:36:40.134    Purge:
Defer delete C:\Windows\$IBM Windows S-TAP$\SetupSupport.dll
`I 07/24/2017 14:36:40.134    Purge:
Defer delete C:\Windows\$IBM Windows S-TAP$\StapInstaller.exe.config
`I 07/24/2017 14:36:40.134    Purge:
Defer delete C:\Windows\$IBM Windows S-TAP$
`I 07/24/2017 14:36:40.134   Finish: The uninstallation completed successfully



Resolving The Problem

1.- Reboot the Windows server. This will resolve the problem.
2.- Verify the S-TAP directory is now gone.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium S-TAP","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.2;10.1.3","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22006484